aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-27 18:37:40 -0300
committerLudovic Courtès <ludo@gnu.org>2020-10-05 10:42:00 +0200
commit558f8d50072f1667840c22d727c83160a27a82c4 (patch)
tree76c0acba2d4128ce8651d8eee7e485a806ae40c2
parent922aae23bf17c1e1a2d20f7cb3f373f33e56dd29 (diff)
downloadguix-558f8d50072f1667840c22d727c83160a27a82c4.tar
guix-558f8d50072f1667840c22d727c83160a27a82c4.tar.gz
gnu: Add gnome-commander.
* gnu/packages/gnome.scm (gnome-commander): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 0947ffbd62..14223841b6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -105,6 +105,7 @@
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages game-development)
+ #:use-module (gnu packages gcc)
#:use-module (gnu packages gettext)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gimp)
@@ -1663,6 +1664,44 @@ uses duplicity as the backend, which supports incremental backups and storage
either on a local, or remote machine via a number of methods.")
(license license:gpl3+)))
+(define-public gnome-commander
+ (package
+ (name "gnome-commander")
+ (version "1.10.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ "gnome-commander-" version ".tar.xz"))
+ (sha256
+ (base32 "0bis36awb73vhkncq8yr0qlnyaxynqkvmyqbg57ijqwd0m8hh4zg"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("gcc" ,gcc-8) ;required for -Wcast-function-type
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("googletest" ,googletest)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("gconf" ,gconf)
+ ("gnome-vfs" ,gnome-vfs)
+ ("gtk+" ,gtk+-2)
+ ("libxml2" ,libxml2)))
+ (home-page "https://gcmd.github.io/")
+ (synopsis "Two-pane graphical file manager for the GNOME desktop")
+ (description
+ "GNOME Commander is a two-pane graphical file manager using GNOME
+libraries. It aims to fulfill the demands of more advanced users who
+like to focus on file management, their work through special applications
+and running smart commands.")
+ (license license:gpl2+)))
+
(define-public gnome-user-docs
(package
(name "gnome-user-docs")