aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-04 23:58:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-05 00:16:57 +0200
commit40dfc5195fa83ba1acab380d80f8391160d0a55d (patch)
tree13e655f595c1f667ff80eac30281688432e354c4
parent9d1afee51cc41fbc3e4c558dacd6223e84a712e6 (diff)
downloadguix-40dfc5195fa83ba1acab380d80f8391160d0a55d.tar
guix-40dfc5195fa83ba1acab380d80f8391160d0a55d.tar.gz
gnu: konversation: Update to 1.7.6.
* gnu/packages/kde-internet.scm (konversation): Update to 1.7.6. [source]: Remove obsolete patch. * gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/kde-internet.scm6
-rw-r--r--gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch24
3 files changed, 3 insertions, 28 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 76d6d7b353..e5bebd9a48 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1204,7 +1204,6 @@ dist_patch_DATA = \
%D%/packages/patches/kodi-increase-test-timeout.patch \
%D%/packages/patches/kodi-set-libcurl-ssl-parameters.patch \
%D%/packages/patches/kodi-skip-test-449.patch \
- %D%/packages/patches/konversation-Fix-build-with-Qt-5.11.patch \
%D%/packages/patches/laby-make-install.patch \
%D%/packages/patches/lcalc-default-parameters-1.patch \
%D%/packages/patches/lcalc-default-parameters-2.patch \
diff --git a/gnu/packages/kde-internet.scm b/gnu/packages/kde-internet.scm
index 800554a36e..6c576223e1 100644
--- a/gnu/packages/kde-internet.scm
+++ b/gnu/packages/kde-internet.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2017, 2019, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
+;;; Copyright © 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -177,15 +178,14 @@ This package is part of the KDE networking module.")
(define-public konversation
(package
(name "konversation")
- (version "1.7.5")
+ (version "1.7.6")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://kde/stable/konversation/" version
"/src/konversation-" version ".tar.xz"))
(sha256
- (base32 "0h098yhlp36ls6pdvs2r93ig8dv4fys62m0h6wxccprb0qrpbgv0"))
- (patches (search-patches "konversation-Fix-build-with-Qt-5.11.patch"))))
+ (base32 "14x0rs867grb1xjddycn9l6bfl3h3rp4cmx4zqd2gsvkihn4zlpx"))))
(build-system qt-build-system)
(native-inputs
`(("extra-cmake-modules" ,extra-cmake-modules)
diff --git a/gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch b/gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch
deleted file mode 100644
index d9d29bbd1a..0000000000
--- a/gnu/packages/patches/konversation-Fix-build-with-Qt-5.11.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 4d0036617becc26a76fd021138c98aceec4c7b53 Mon Sep 17 00:00:00 2001
-From: Luca Beltrame <lbeltrame@kde.org>
-Date: Sun, 21 Jul 2019 09:14:32 +0200
-Subject: Fix build with Qt 5.13
-
----
- src/irc/outputfilter.cpp | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/irc/outputfilter.cpp b/src/irc/outputfilter.cpp
-index f9e6253..45d11fb 100644
---- a/src/irc/outputfilter.cpp
-+++ b/src/irc/outputfilter.cpp
-@@ -32,6 +32,7 @@
-
- #include <QStringList>
- #include <QFile>
-+#include <QMetaMethod>
- #include <QRegExp>
- #include <QTextCodec>
- #include <QByteArray>
---
-cgit v1.1
-