aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-09-27 20:08:55 -0300
committerLudovic Courtès <ludo@gnu.org>2020-10-05 10:42:00 +0200
commit203cf9d673c3bf12b3efe2cb7006a477301c73a8 (patch)
tree77693db364148583ce20c595d97ad9cb1a187898
parent558f8d50072f1667840c22d727c83160a27a82c4 (diff)
downloadguix-203cf9d673c3bf12b3efe2cb7006a477301c73a8.tar
guix-203cf9d673c3bf12b3efe2cb7006a477301c73a8.tar.gz
gnu: Add gnote.
* gnu/packages/gnome.scm (gnote): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 14223841b6..7c9f23880b 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -10930,6 +10930,44 @@ versions of Adwaita, Adwaita-dark and HighContrast themes. It also provides
index files needed for Adwaita to be used outside of GNOME.")
(license license:lgpl2.1+)))
+(define-public gnote
+ (package
+ (name "gnote")
+ (version "3.38.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ "gnote-" version ".tar.xz"))
+ (sha256
+ (base32 "1ingbaw4d8vpjn083xvzqw7kz8z0k2bx7msk78pbzd68bwgkadpx"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("desktop-file-utils" ,desktop-file-utils)
+ ("glib:bin" ,glib "bin")
+ ("gobject-introspection" ,gobject-introspection)
+ ("intltool" ,intltool)
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("unittest-cpp" ,unittest-cpp))) ;FIXME: not found by pkg-config
+ (inputs
+ `(("glibmm" ,glibmm)
+ ("gsettings-desktop-schemas" ,gsettings-desktop-schemas)
+ ("gspell" ,gspell)
+ ("gtk+" ,gtk+)
+ ("gtkmm" ,gtkmm)
+ ("libsecret" ,libsecret)
+ ("libuuid" ,util-linux "lib")
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)))
+ (synopsis "Note-taking application for the GNOME desktop")
+ (description
+ "Gnote is a note-taking application written for the GNOME desktop
+environment.")
+ (home-page "https://wiki.gnome.org/Apps/Gnote")
+ (license license:gpl3+)))
+
(define-public polari
(package
(name "polari")