aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-12-28 14:36:22 +0100
committerLeo Famulari <leo@famulari.name>2020-12-30 17:53:17 -0500
commit9d6863de245fc061f24693b58ce87e73fe299d31 (patch)
tree80d71713a7b37ad1d8c9358a4efcc5850a73e985
parent50abaf63879c93e0ea0e09883defe639396fb04c (diff)
downloadguix-9d6863de245fc061f24693b58ce87e73fe299d31.tar
guix-9d6863de245fc061f24693b58ce87e73fe299d31.tar.gz
gnu: borg: Install shell completions.
* gnu/packages/backup.scm (borg)[arguments]: Add new 'install-shell-completions' phase. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/backup.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 64fc23bf4c..ce6ea7fd49 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Marcin Karpezo <sirmacik@wioo.waw.pl>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -672,6 +673,19 @@ detection, and lossless compression.")
"docs/misc/internals-picture.txt"
"docs/misc/prune-example.txt"))
(copy-recursively "docs/man" man)
+ #t)))
+ (add-after 'install-docs 'install-shell-completions
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (etc (string-append out "/etc"))
+ (share (string-append out "/share")))
+ (with-directory-excursion "scripts/shell_completions"
+ (install-file "bash/borg"
+ (string-append etc "/bash_completion.d"))
+ (install-file "zsh/_borg"
+ (string-append share "/zsh/site-functions"))
+ (install-file "fish/borg.fish"
+ (string-append share "/fish/vendor_completions.d")))
#t))))))
(native-inputs
`(("python-cython" ,python-cython)