aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-30 10:18:54 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2020-12-30 10:19:10 -0500
commit452cd4094e79655339087d16831b71277f017a57 (patch)
tree891d4f70c1ffcb735bdc64395c3bc1683d42e49c
parent05c8c4f61fe3d5f70f705729e48e91a5c5927090 (diff)
downloadguix-452cd4094e79655339087d16831b71277f017a57.tar
guix-452cd4094e79655339087d16831b71277f017a57.tar.gz
gnu: Add python-caniusepython3.
* gnu/packages/python-xyz.scm (python-caniusepython3): New variable.
-rw-r--r--gnu/packages/python-xyz.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 43d767b1f0..818a244378 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1354,6 +1354,46 @@ abstractions to different hardware devices, and a suite of utilities for
sending and receiving messages on a CAN bus.")
(license license:lgpl3+)))
+(define-public python-caniusepython3
+ (package
+ (name "python-caniusepython3")
+ (version "7.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "caniusepython3" version))
+ (sha256
+ (base32
+ "0a755444ln38j8d7xb3yw0wzpd0mjrzfn6zqvsh06nw1vdaq4l28"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'relax-requirements
+ (lambda _
+ (substitute* "setup.py"
+ ;; These are for compatibility with Python 2.
+ ((".*'argparse', 'backports.functools_lru_cache',.*")
+ ""))
+ (substitute* "dev_requirements.txt"
+ ((".*pylint.*") "")) ;not actually required
+ #t))
+ (replace 'check
+ (lambda _
+ (invoke "py.test" "-k" "not NetworkTests"))))))
+ (propagated-inputs
+ `(("python-distlib" ,python-distlib)
+ ("python-packaging" ,python-packaging)
+ ("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/brettcannon/caniusepython3")
+ (synopsis "Check for Python 3-incompatible Python libraries")
+ (description "The @command{caniusepython3} command scans your project and
+reports the Python 3-incompatible libraries it found. It can also be used as
+a library.")
+ (license license:asl2.0)))
+
(define-public python-diskcache
(package
(name "python-diskcache")