aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-05-21 04:53:44 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-21 06:02:10 +0200
commitb3200505efd1e77c5b3213d6afd61e30eb5ca691 (patch)
treee1c6fe67a059117b6cfe7150d6eeea9bd3ae3137
parent0523ab2cb28c4700620952a451e1aaa61cd7924b (diff)
downloadguix-b3200505efd1e77c5b3213d6afd61e30eb5ca691.tar
guix-b3200505efd1e77c5b3213d6afd61e30eb5ca691.tar.gz
gnu: python-apipkg: Update to 1.5.
* gnu/packages/python-xyz.scm (python-apipkg): Update to 1.5. [native-inputs]: Add python-setuptools-scm.
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 02e406e5f5..5c0f0bda82 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9478,16 +9478,17 @@ applications.")
(define-public python-apipkg
(package
(name "python-apipkg")
- (version "1.4")
+ (version "1.5")
(source (origin
(method url-fetch)
(uri (pypi-uri "apipkg" version))
(sha256
(base32
- "1iks5701qnp3dlr3q1d9qm68y2plp2m029irhpz92a44psfkjf1f"))))
+ "1xhak74yj3lqflvpijg15rnkklrigvsp5q7s4as4h6a157d8q8ip"))))
(build-system python-build-system)
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-pytest" ,python-pytest)
+ ("python-setuptools-scm" ,python-setuptools-scm)))
(synopsis "Namespace control and lazy-import mechanism")
(description "With apipkg you can control the exported namespace of a Python
package and greatly reduce the number of imports for your users. It is a small