aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-17 16:23:29 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-20 23:51:27 +0200
commitab9de8cfb0525ef43668712ac898707f97f9a620 (patch)
tree56e71ade29753cd1df227496b1eec343194bd617
parent453e66d7772a2182244e35dd6224a73f97cfc07d (diff)
downloadguix-ab9de8cfb0525ef43668712ac898707f97f9a620.tar
guix-ab9de8cfb0525ef43668712ac898707f97f9a620.tar.gz
gnu: fontconfig: Add replacement with font-dejavu instead of gs-fonts.
This fixes <https://bugs.gnu.org/41282>, <https://bugs.gnu.org/41241>, and <https://bugs.gnu.org/41344>. Reported by Pierre Neidhardt, W Knight, Alexandros Theodotou, and others. * gnu/packages/fontutils.scm (fontconfig)[replacement]: New field. (fontconfig/font-dejavu): New variable.
-rw-r--r--gnu/packages/fontutils.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index e552ece50b..ab9bd4346f 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -37,6 +37,7 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages gettext)
#:use-module (gnu packages python)
#:use-module (gnu packages python-xyz)
@@ -292,6 +293,12 @@ fonts to/from the WOFF2 format.")
(define-public fontconfig
(package
(name "fontconfig")
+
+ ;; This replacement is not security-related, but works around the fact
+ ;; that gs-fonts are not recognized by newer versions of Pango, causing
+ ;; many applications to fail to find fonts otherwise.
+ (replacement fontconfig/font-dejavu)
+
(version "2.13.1")
(source (origin
(method url-fetch)
@@ -348,6 +355,13 @@ high quality, anti-aliased and subpixel rendered text on a display.")
"See COPYING in the distribution."))
(home-page "https://www.freedesktop.org/wiki/Software/fontconfig")))
+(define fontconfig/font-dejavu
+ (package
+ (inherit fontconfig)
+ (inputs
+ ;; XXX: Reuse the name to avoid having to override the configure flags.
+ `(("gs-fonts" ,font-dejavu)))))
+
(define-public t1lib
(package
(name "t1lib")