aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdouard Klein <edk@beaver-labs.com>2020-05-13 09:52:45 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-20 23:51:27 +0200
commit1e3cf9de840c6968f73b6b6c515dd870563b05cb (patch)
tree06149f7424acd9d0a0168bf8b769dd964df0dd2d
parentab9de8cfb0525ef43668712ac898707f97f9a620 (diff)
downloadguix-1e3cf9de840c6968f73b6b6c515dd870563b05cb.tar
guix-1e3cf9de840c6968f73b6b6c515dd870563b05cb.tar.gz
gnu: Add python-random-user-agent.
* gnu/packages/python-web.scm (python-random-user-agent): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 05fd1599a1..00caf7f229 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4004,3 +4004,23 @@ changed the process is restarted.")
"Pyramid makes it easy to write web applications. From minimal
request/response web apps to larger, grown applications.")
(license license:repoze)))
+
+(define-public python-random-user-agent
+ (package
+ (name "python-random-user-agent")
+ (version "1.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "random_user_agent" version))
+ (sha256
+ (base32
+ "04nhzdh2ki7ybhjrmghxci6hcm6i03vvin2q2ynj87fbr1pa534g"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/Luqman-Ud-Din/random_user_agent")
+ (synopsis "List of user agents")
+ (description
+ "This package provides a list of user agents, from a collection of more
+than 326,000 known user-agents. Users can pick a random one, or select one
+based on filters.")
+ (license license:expat)))