aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2020-05-07 18:19:34 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2020-05-21 11:53:06 +0200
commit09db7f39ba9660f5f5a3f6cfa2e54ee6df8d9dd4 (patch)
treefc58e698d29a62e9791ed5f0994f1dae261eaafb
parentc3f1f09586967c3fefbb280014a4d46b57786696 (diff)
downloadguix-09db7f39ba9660f5f5a3f6cfa2e54ee6df8d9dd4.tar
guix-09db7f39ba9660f5f5a3f6cfa2e54ee6df8d9dd4.tar.gz
gnu: cl-dexador: Fix build with new sbcl-package->cl-source-package function.
* gnu/packages/lisp-xyz.scm (cl-dexador)[arguments]: Remove 'reset-gzip-timestamps phase.
-rw-r--r--gnu/packages/lisp-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 60fb4b0487..f0f28ae8f3 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -5867,8 +5867,8 @@ neat APIs and connection-pooling. It is meant to supersede Drakma.")
;; asdf-build-system/source has its own phases and does not inherit
;; from asdf-build-system/sbcl phases.
(modify-phases %standard-phases/source
- (add-after 'unpack 'fix-permissions
- (lambda _ (make-file-writable "t/data/test.gz") #t)))))))
+ ;; Already done in SBCL package.
+ (delete 'reset-gzip-timestamps))))))
(define-public ecl-dexador
(sbcl-package->ecl-package sbcl-dexador))