aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-07-12 21:10:02 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-07-20 23:19:24 +0530
commitcfd6a3b1ee6b8c64d5e370f2a461a7882dbe58ab (patch)
treeb4b3f578cf7b861619a053b2256cde9ad805161d
parentdbfcadfc304bf2dab73f4e88377e7fe902e1ca72 (diff)
downloadguix-cfd6a3b1ee6b8c64d5e370f2a461a7882dbe58ab.tar
guix-cfd6a3b1ee6b8c64d5e370f2a461a7882dbe58ab.tar.gz
gnu: Add bmon.
* gnu/packages/networking.scm (bmon): New variable.
-rw-r--r--gnu/packages/networking.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index ef50756ddf..2f4d3d233e 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016, 2017 ng0 <ng0@libertad.pw>
-;;; Copyright © 2016 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2016 Benz Schenk <benz.schenk@uzh.ch>
;;; Copyright © 2016, 2017 Pjotr Prins <pjotr.guix@thebird.nl>
;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
@@ -70,6 +70,7 @@
#:use-module (gnu packages textutils)
#:use-module (gnu packages tls)
#:use-module (gnu packages valgrind)
+ #:use-module (gnu packages wm)
#:use-module (gnu packages xml)
#:use-module (ice-9 match))
@@ -1395,3 +1396,35 @@ newer and only works on Ethernet network interfaces.")
;; AGPL 3 with exception for linking with OpenSSL. See the 'LICENSE' file in
;; the source distribution for more information.
(license license:agpl3)))
+
+(define-public bmon
+ (package
+ (name "bmon")
+ (version "4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/tgraf/bmon/releases/download/v"
+ version "/bmon-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0ylzriv4pwh76344abzl1w219x188gshbycbna35gsyfp09c7z82"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libconfuse" ,libconfuse)
+ ("libnl" ,libnl)
+ ("ncurses" ,ncurses)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (synopsis "Bandwidth monitor")
+ (description "bmon is a monitoring and debugging tool to capture
+networking-related statistics and prepare them visually in a human-friendly
+way. It features various output methods including an interactive curses user
+interface and a programmable text output for scripting.")
+ (home-page "https://github.com/tgraf/bmon")
+ ;; README.md mentions both the 2-clause BSD and expat licenses, but all
+ ;; the source files only have expat license headers. Upstream has been
+ ;; contacted for clarification: https://github.com/tgraf/bmon/issues/59
+ ;; Update the license field when upstream responds.
+ (license (list license:bsd-2
+ license:expat))))