aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-09 23:06:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-18 09:58:56 +0200
commit8b89c1717c033a4c2dbd1ff4060d5f78e5d037ef (patch)
tree97a06497f012e59e18ddedcbc840a57ed0c72bd6
parent2805f9b2a026a34d3e1069e86293ab3e18cadd9f (diff)
downloadguix-8b89c1717c033a4c2dbd1ff4060d5f78e5d037ef.tar
guix-8b89c1717c033a4c2dbd1ff4060d5f78e5d037ef.tar.gz
gnu: python-numpy-documentation: Use texlive-union.
* gnu/packages/python.scm (python-numpy-documentation)[native-inputs]: Replace "texlive" with a texlive-union.
-rw-r--r--gnu/packages/python.scm39
1 files changed, 38 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7b214d2cf0..91ef226036 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3720,7 +3720,39 @@ association studies (GWAS) on extremely large data sets.")
("pkg-config" ,pkg-config)
("python-sphinx" ,python-sphinx)
("python-numpydoc" ,python-numpydoc)
- ("texlive" ,texlive)
+ ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ texlive-fonts-ec
+ texlive-generic-ifxetex
+ texlive-generic-pdftex
+ texlive-latex-amsfonts
+ texlive-latex-capt-of
+ texlive-latex-cmap
+ texlive-latex-environ
+ texlive-latex-eqparbox
+ texlive-latex-etoolbox
+ texlive-latex-expdlist
+ texlive-latex-fancyhdr
+ texlive-latex-fancyvrb
+ texlive-latex-fncychap
+ texlive-latex-float
+ texlive-latex-framed
+ texlive-latex-geometry
+ texlive-latex-graphics
+ texlive-latex-hyperref
+ texlive-latex-mdwtools
+ texlive-latex-multirow
+ texlive-latex-oberdiek
+ texlive-latex-parskip
+ texlive-latex-preview
+ texlive-latex-tabulary
+ texlive-latex-threeparttable
+ texlive-latex-titlesec
+ texlive-latex-trimspaces
+ texlive-latex-ucs
+ texlive-latex-upquote
+ texlive-latex-url
+ texlive-latex-varwidth
+ texlive-latex-wrapfig)))
("texinfo" ,texinfo)
("perl" ,perl)
("scipy-sphinx-theme"
@@ -3749,6 +3781,11 @@ association studies (GWAS) on extremely large data sets.")
(scipy-sphinx-theme "scipy-sphinx-theme")
(sphinx-theme-checkout (assoc-ref inputs scipy-sphinx-theme))
(pyver ,(string-append "PYVER=")))
+
+ ;; FIXME: this is needed to for texlive-union to generate
+ ;; fonts, which are not found.
+ (setenv "HOME" "/tmp")
+
(with-directory-excursion "doc"
(copy-recursively sphinx-theme-checkout scipy-sphinx-theme)
(mkdir-p html)