aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-11 09:03:10 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-19 22:27:02 +0200
commit5f94ec913f9bfda05aa8a5e7993ff95c38d23a08 (patch)
tree4165151e1cabea0bf9ef23417862519cfcad8f56
parent423d2136f0ed0eafdae60d7fcedc7f24d2ee3344 (diff)
downloadguix-5f94ec913f9bfda05aa8a5e7993ff95c38d23a08.tar
guix-5f94ec913f9bfda05aa8a5e7993ff95c38d23a08.tar.gz
gnu: Add python-sphinxcontrib-websupport.
* gnu/packages/python.scm (python-sphinxcontrib-websupport): New variable.
-rw-r--r--gnu/packages/python.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index ebfd298938..e5fd71ef1b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -100,6 +100,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
#:use-module (gnu packages sdl)
+ #:use-module (gnu packages search)
#:use-module (gnu packages shells)
#:use-module (gnu packages ssh)
#:use-module (gnu packages statistics)
@@ -3161,6 +3162,36 @@ reStructuredText.")
(define-public python2-pygments
(package-with-python2 python-pygments))
+(define-public python-sphinxcontrib-websupport
+ (package
+ (name "python-sphinxcontrib-websupport")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "sphinxcontrib-websupport" version))
+ (sha256
+ (base32
+ "1f9f0wjpi9nhikbyaz6d19s7qvzdf1nq2g5dsh640fma4q9rd1bs"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-xapian-bindings" ,python-xapian-bindings)))
+ ;; Needed for running the test suite
+ (native-inputs
+ `(("python-six" ,python-six)
+ ("python-jinja2" ,python-jinja2)
+ ("python-docutils" ,python-docutils)
+ ("python-sphinx" ,python-sphinx)
+ ("python-sqlalchemy" ,python-sqlalchemy)
+ ("python-whoosh" ,python-whoosh)))
+ (home-page "http://sphinx-doc.org/")
+ (synopsis "Sphinx API for web applications")
+ (description "This package provides a Python API to easily integrate
+Sphinx documentation into your web application. It provides tools to
+integrate Sphinx documents in web templates and to handle searches.")
+ (license license:bsd-3)))
+
(define-public python-sphinx
(package
(name "python-sphinx")