aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-20 01:35:45 -0400
committerLeo Famulari <leo@famulari.name>2017-07-21 15:20:23 -0400
commit3c14378381fc1f187a07b2f958eeed1958f02672 (patch)
treea13dba90c458fff36a0e165fe6fb7d610dd6a9b9
parent6f226c078c5dceddd7fbcba8f878f101e5bffd9a (diff)
downloadguix-3c14378381fc1f187a07b2f958eeed1958f02672.tar
guix-3c14378381fc1f187a07b2f958eeed1958f02672.tar.gz
gnu: vim: Update to 8.0.0727 [fixes CVE-2017-11109].
* gnu/packages/vim.scm (vim): Update to 8.0.0727. (vim-full)[source]: Add field and hold back at version 8.0.0600.
-rw-r--r--gnu/packages/vim.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 27c0b0da9c..f8c9761924 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -60,7 +60,7 @@
(define-public vim
(package
(name "vim")
- (version "8.0.0600")
+ (version "8.0.0727")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/vim/vim/archive/v"
@@ -68,7 +68,7 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1ifaj0lfzqn06snkcd83l58m9r6lg7lk3wspx71k5ycvypyfi67s"))))
+ "0hwqglpsk8qlp2rn6q9p35fxk88xixljk1yv42m3j01g3bgqg0gx"))))
(build-system gnu-build-system)
(arguments
`(#:test-target "test"
@@ -111,8 +111,20 @@ configuration files.")
(define-public vim-full
(package
+ ;; This package should share its source with Vim, but it doesn't
+ ;; build reliably, and we want to keep Vim up to date due to the
+ ;; frequency of important bug fixes.
(inherit vim)
(name "vim-full")
+ (version "8.0.0600")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/vim/vim/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1ifaj0lfzqn06snkcd83l58m9r6lg7lk3wspx71k5ycvypyfi67s"))))
(arguments
`(#:configure-flags
(list (string-append "--with-lua-prefix="