aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Brielmaier <jonathan.brielmaier@web.de>2017-07-14 00:28:14 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-20 00:54:52 +0200
commit29ac89a6355303118bd119fa68bbeb13206bf519 (patch)
tree5ee6828bf0134c57f4459dad08a0e4d32d83e11a
parent05c88516955814ac61dc7578017e1976c43a1cd3 (diff)
downloadguix-29ac89a6355303118bd119fa68bbeb13206bf519.tar
guix-29ac89a6355303118bd119fa68bbeb13206bf519.tar.gz
gnu: Add 0xffff.
* gnu/packages/flashing-tools.scm (0xffff): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/flashing-tools.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/flashing-tools.scm b/gnu/packages/flashing-tools.scm
index f25c25fbfb..127fc795a3 100644
--- a/gnu/packages/flashing-tools.scm
+++ b/gnu/packages/flashing-tools.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2016 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2017 Jonathan Brielmaier <jonathan.brielmaier@web.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -82,6 +83,37 @@ network/graphics/storage controller cards, and various other
programmer devices.")
(license gpl2)))
+(define-public 0xffff
+ (package
+ (name "0xffff")
+ (version "0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/pali/0xffff/archive/"
+ version ".tar.gz"))
+ (file-name (string-append "0xFFFF" version ".tar.gz" ))
+ (sha256
+ (base32
+ "1g4032c81wkk37wvbg1dxcqq6mnd76y9x7f2crmzqi6z4q9jcxmj"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("libusb",libusb-0.1))) ; doesn't work with libusb-compat
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)) ; no configure
+ #:make-flags (list (string-append "PREFIX=" %output))
+ #:tests? #f)) ; no 'check' target
+ (home-page "https://github.com/pali/0xFFFF")
+ (synopsis "Flash FIASCO images on Maemo devices")
+ (description
+ "The Open Free Fiasco Firmware Flasher (0xFFFF) is a flashing tool
+for FIASCO images. It supports generating, unpacking, editing and
+flashing of FIASCO images for Maemo devices. Use it with care. It can
+brick your device.")
+ (license gpl3+)))
+
(define-public avrdude
(package
(name "avrdude")