aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-15 10:38:29 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-17 14:01:46 +0200
commit2584beaedd04c5f8b1278441160bf3531e81e9bf (patch)
tree5012234b4ee21ea4b8cc01fe330cf80fa19d6707
parent5a1ee7d83556599b004ad6cf5561ae3c97b0e125 (diff)
downloadguix-2584beaedd04c5f8b1278441160bf3531e81e9bf.tar
guix-2584beaedd04c5f8b1278441160bf3531e81e9bf.tar.gz
gnu: python-ipython: Use texlive-union.
* gnu/packages/python.scm (python-ipython)[native-inputs]: Replace "texlive" with a texlive-union.
-rw-r--r--gnu/packages/python.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 1c53956fb1..f9c6176c10 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5465,7 +5465,40 @@ tools for mocking system commands and recording calls to those.")
("python-nose" ,python-nose)
("python-sphinx" ,python-sphinx)
("python-shpinx-rtd-theme" ,python-sphinx-rtd-theme)
- ("texlive" ,texlive)
+ ;; FIXME: It's possible that a smaller union would work just as well.
+ ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ texlive-fonts-ec
+ texlive-generic-ifxetex
+ texlive-generic-pdftex
+ texlive-latex-amsfonts
+ texlive-latex-capt-of
+ texlive-latex-cmap
+ texlive-latex-environ
+ texlive-latex-eqparbox
+ texlive-latex-etoolbox
+ texlive-latex-expdlist
+ texlive-latex-fancyhdr
+ texlive-latex-fancyvrb
+ texlive-latex-fncychap
+ texlive-latex-float
+ texlive-latex-framed
+ texlive-latex-geometry
+ texlive-latex-graphics
+ texlive-latex-hyperref
+ texlive-latex-mdwtools
+ texlive-latex-multirow
+ texlive-latex-oberdiek
+ texlive-latex-parskip
+ texlive-latex-preview
+ texlive-latex-tabulary
+ texlive-latex-threeparttable
+ texlive-latex-titlesec
+ texlive-latex-trimspaces
+ texlive-latex-ucs
+ texlive-latex-upquote
+ texlive-latex-url
+ texlive-latex-varwidth
+ texlive-latex-wrapfig)))
("texinfo" ,texinfo)))
(arguments
`(#:phases