aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPkill -9 <pkill9@runbox.com>2019-03-23 11:49:52 +0000
committerLudovic Courtès <ludo@gnu.org>2019-03-24 23:06:12 +0100
commitfab9aa1daa5d4ebcd80d934a6f00db4a1e6afb8a (patch)
tree0c4738322bc6467f0ab54260638ec9da0eadf65e
parent2bbb4ead771fcb29266607b338b21c6dd97e3f69 (diff)
downloadguix-fab9aa1daa5d4ebcd80d934a6f00db4a1e6afb8a.tar
guix-fab9aa1daa5d4ebcd80d934a6f00db4a1e6afb8a.tar.gz
gnu: Add xfce4-whiskermenu-plugin.
* gnu/packages/xfce.scm (xfce4-whiskermenu-plugin): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/xfce.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 6c253849f6..8543dcffed 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017 ng0 <ng0@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -29,6 +30,7 @@
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix utils)
+ #:use-module (guix build-system cmake)
#:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system trivial)
@@ -406,6 +408,39 @@ to an auto mixer tool like pavucontrol. It can optionally handle multimedia
keys for controlling the audio volume.")
(license gpl2+)))
+(define-public xfce4-whiskermenu-plugin
+ (package
+ (name "xfce4-whiskermenu-plugin")
+ (version "2.3.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://archive.xfce.org/src/panel-plugins/"
+ name "/" (version-major+minor version) "/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1cnas2x7xi53v6ylq44040narhzd828dc0ysz8yk3qn2mmvp5yr2"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("xfce4-panel" ,xfce4-panel)
+ ("garcon" ,garcon)
+ ("exo" ,exo)
+ ("gtk+" ,gtk+-2)))
+ (arguments
+ `(#:tests? #f)) ; no tests
+ (home-page "https://goodies.xfce.org/projects/panel-plugins/xfce4-whiskermenu-plugin")
+ (synopsis "Application menu panel plugin for Xfce")
+ (description
+ "This package provides an alternative to the default application menu
+panel plugin for Xfce4. It uses separate sections to display categories and
+applications, and includes a search bar to search for applications.")
+ ;; The main plugin code is covered by gpl2, but files in panel-plugin directory
+ ;; are covered by gpl2+. The SVG icon is covered by gpl2.
+ (license (list gpl2 gpl2+))))
+
(define-public xfce4-xkb-plugin
(package
(name "xfce4-xkb-plugin")