aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-24 11:39:35 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-24 20:36:51 +0100
commitf98d97c6f2ca00775a4c0e28889827318eb57a65 (patch)
treebf0091c630c26eb882dd57abd273f65f5f549101
parent9ebb7f8181f9fa306236805757f6c7a3365ad666 (diff)
downloadguix-f98d97c6f2ca00775a4c0e28889827318eb57a65.tar
guix-f98d97c6f2ca00775a4c0e28889827318eb57a65.tar.gz
gnu: Add r-lemon.
* gnu/packages/cran.scm (r-lemon): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 88d0bcdde9..c30112ce73 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11823,3 +11823,31 @@ algorithms as described in Sutton & Barto (1998). The Q-Learning algorithm
can be used with function approximation, eligibility traces (Singh & Sutton,
1996) and experience replay (Mnih et al., 2013).")
(license license:expat)))
+
+(define-public r-lemon
+ (package
+ (name "r-lemon")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lemon" version))
+ (sha256
+ (base32
+ "0wsn5bfg10wq4dnrgpyraz2bzx9p19c7hf1pwj3h4zmpqfgsdbpw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-gridextra" ,r-gridextra)
+ ("r-gtable" ,r-gtable)
+ ("r-knitr" ,r-knitr)
+ ("r-lattice" ,r-lattice)
+ ("r-plyr" ,r-plyr)
+ ("r-scales" ,r-scales)))
+ (home-page "https://github.com/stefanedwards/lemon")
+ (synopsis "Freshen up your ggplot2 plots")
+ (description
+ "This package provides functions for working with legends and axis lines
+of ggplot2, facets that repeat axis lines on all panels, and some knitr
+extensions.")
+ (license license:gpl3)))