aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-24 23:41:19 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-24 23:44:13 +0100
commit3d2bc817517d9ff69e3eb255d078dad76305bedd (patch)
tree9e8bad527cfde51f7c66bed1857d33bea104d3bc
parent91c1fbdfdd2b18ae3c77c150d558c7947276d59e (diff)
downloadguix-3d2bc817517d9ff69e3eb255d078dad76305bedd.tar
guix-3d2bc817517d9ff69e3eb255d078dad76305bedd.tar.gz
gnu: Add r-pegas.
* gnu/packages/cran.scm (r-pegas): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b1466dc27b..7273989e49 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12305,3 +12305,29 @@ statistical tests, simulation tools, distance and similarity measures, and
several spatial methods. A range of both empirical and simulated datasets is
also provided to illustrate various methods.")
(license license:gpl2+)))
+
+(define-public r-pegas
+ (package
+ (name "r-pegas")
+ (version "0.11")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pegas" version))
+ (sha256
+ (base32
+ "0l21bapzbjcvblbvks3jh9rpy9hng1ccd7f0glhqw695lc737bpx"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-adegenet" ,r-adegenet)
+ ("r-ape" ,r-ape)))
+ (home-page "http://ape-package.ird.fr/pegas.html")
+ (synopsis "Population and evolutionary genetics analysis system")
+ (description
+ "This package provides functions for reading, writing, plotting,
+analysing, and manipulating allelic and haplotypic data, including from VCF
+files, and for the analysis of population nucleotide sequences and
+micro-satellites including coalescent analyses, linkage disequilibrium,
+population structure (Fst, Amova) and equilibrium (HWE), haplotype networks,
+minimum spanning tree and network, and median-joining networks.")
+ (license license:gpl2+)))