aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-24 22:57:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-24 23:44:12 +0100
commit2a35bb1509a3f5ed3618b37de8dc4c020266d514 (patch)
treea5181fcf887e8547e6f09cd782215afc5341801f
parentea87b4e37d56bae7c8262c9d539ecfc9fae5e0fa (diff)
downloadguix-2a35bb1509a3f5ed3618b37de8dc4c020266d514.tar
guix-2a35bb1509a3f5ed3618b37de8dc4c020266d514.tar.gz
gnu: Add r-snpmaxsel.
* gnu/packages/cran.scm (r-snpmaxsel): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 12c3989b18..6b45e6c9d4 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -11996,3 +11996,27 @@ Hubbell's @dfn{Unified Neutral Theory of Biodiversity} (UNTB).")
"This package provides a stepwise approach to identifying recombination
breakpoints in a genomic sequence alignment.")
(license license:gpl2+)))
+
+(define-public r-snpmaxsel
+ (package
+ (name "r-snpmaxsel")
+ (version "1.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "SNPmaxsel" version))
+ (sha256
+ (base32
+ "0pjvixwqzjd3jwccc8yqq9c76afvbmfq0z1w0cwyj8bblrjpx13z"))))
+ (properties `((upstream-name . "SNPmaxsel")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-combinat" ,r-combinat)
+ ("r-mvtnorm" ,r-mvtnorm)))
+ (home-page "https://cran.r-project.org/web/packages/SNPmaxsel/index.html")
+ (synopsis "Maximally selected statistics for SNP data")
+ (description
+ "This package implements asymptotic methods related to maximally selected
+statistics, with applications to @dfn{single-nucleotide polymorphism} (SNP)
+data.")
+ (license license:gpl2+)))