aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-24 22:26:50 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-24 23:06:10 +0100
commit16360cc884030eb69590dc18d9694b04c67273f6 (patch)
treeaceb1da468da7ae18acbcce5b34098f3a4402b6e
parent37f628960516cd49f6bce37366949e5255bfa5e7 (diff)
downloadguix-16360cc884030eb69590dc18d9694b04c67273f6.tar
guix-16360cc884030eb69590dc18d9694b04c67273f6.tar.gz
gnu: flatpak: Use glib-or-gtk-build-system.
This wraps 'flatpak' such that GIO_EXTRA_MODULES is set, thereby allowing GIO (part of GLib) to find the GnuTLS-based TLS backend that glib-networking provides. Fixes <https://bugs.gnu.org/34861>. Reported by Raghav Gururajan <rvgn@disroot.org>. * gnu/packages/package-management.scm (flatpak)[build-system]: Change to GLIB-OR-GTK-BUILD-SYSTEM.
-rw-r--r--gnu/packages/package-management.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 86e8fce1dc..0b70ae4cf4 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -78,6 +78,7 @@
#:use-module (gnu packages web)
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg)
+ #:use-module (guix build-system glib-or-gtk)
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
@@ -1018,7 +1019,11 @@ the bootloader configuration.")
(sha256
(base32
"0i0dn3w3545lvmjlzqj3j70lk8yrq64r9frp1rk6a161gwq20ixv"))))
- (build-system gnu-build-system)
+
+ ;; Wrap 'flatpak' so that GIO_EXTRA_MODULES is set, thereby allowing GIO to
+ ;; find the TLS backend in glib-networking.
+ (build-system glib-or-gtk-build-system)
+
(arguments
'(#:tests? #f ;; Tests fail due to trying to create files where it can't.
#:configure-flags (list