aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:26:50 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:08 +0200
commitd3c67e1b45865b96122ba249280a7b61ce1850d4 (patch)
tree805a7f18e7963b37cda1bf832f8c2b822dade5e4
parent05486604205567c47cf835277009b9897671b5ab (diff)
downloadguix-d3c67e1b45865b96122ba249280a7b61ce1850d4.tar
guix-d3c67e1b45865b96122ba249280a7b61ce1850d4.tar.gz
gnu: Add r-dendextend.
* gnu/packages/cran.scm (r-dendextend): New variable.
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 25f52a1433..b2502e1826 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -309,3 +309,32 @@ comparison object. If the objects are not identical, the functions can be
instructed to explore various modifications of the objects (e.g., sorting
rows, dropping names) to see if the modified versions are identical.")
(license license:gpl2+)))
+
+(define-public r-dendextend
+ (package
+ (name "r-dendextend")
+ (version "1.5.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dendextend" version))
+ (sha256
+ (base32
+ "04jz58apibfrkjcrdmw2hmsav6qpb5cs6qdai81k1v1iznfcya42"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fpc" ,r-fpc)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-magrittr" ,r-magrittr)
+ ("r-viridis" ,r-viridis)
+ ("r-whisker" ,r-whisker)))
+ (home-page "https://cran.r-project.org/web/packages/dendextend")
+ (synopsis "Extending 'dendrogram' functionality in R")
+ (description
+ "This package offers a set of functions for extending @code{dendrogram}
+objects in R, letting you visualize and compare trees of hierarchical
+clusterings. You can adjust a tree's graphical parameters (the color, size,
+type, etc of its branches, nodes and labels) and visually and statistically
+compare different dendrograms to one another.")
+ ;; Any of these versions
+ (license (list license:gpl2 license:gpl3))))