aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-07-12 23:03:32 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-08-18 16:54:58 +0530
commitc5361b7c3da564624e650d62140cb508afcb082e (patch)
treebdfe67554295a512924a175a995f00db98056f48
parented464f48efd80e6439441d7a9f6d0e7988fb1272 (diff)
downloadguix-c5361b7c3da564624e650d62140cb508afcb082e.tar
guix-c5361b7c3da564624e650d62140cb508afcb082e.tar.gz
gnu: Add rtl-sdr.
* gnu/packages/ham-radio.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/packages/ham-radio.scm (rtl-sdr): New variable.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/ham-radio.scm52
2 files changed, 53 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b4acd0ca36..1abdeca830 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -196,6 +196,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/gv.scm \
%D%/packages/gxmessage.scm \
%D%/packages/haskell.scm \
+ %D%/packages/ham-radio.scm \
%D%/packages/hexedit.scm \
%D%/packages/hugs.scm \
%D%/packages/hurd.scm \
diff --git a/gnu/packages/ham-radio.scm b/gnu/packages/ham-radio.scm
new file mode 100644
index 0000000000..0f96553c65
--- /dev/null
+++ b/gnu/packages/ham-radio.scm
@@ -0,0 +1,52 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages ham-radio)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix download)
+ #:use-module (gnu packages libusb)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (guix build-system cmake))
+
+(define-public rtl-sdr
+ (package
+ (name "rtl-sdr")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://cgit.osmocom.org/rtl-sdr/snapshot/rtl-sdr-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "08awca3v28sa4lxym4r81pzf0la0j86wbmpyhv3xd53an9gkpjy9"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("libusb" ,libusb)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags '("-DDETACH_KERNEL_DRIVER=ON")
+ #:tests? #f)) ; No tests
+ (home-page "https://osmocom.org/projects/sdr/wiki/rtl-sdr")
+ (synopsis "Software defined radio driver for Realtek RTL2832U")
+ (description "DVB-T dongles based on the Realtek RTL2832U can be used as a
+cheap software defined radio, since the chip allows transferring the raw I/Q
+samples to the host. @code{rtl-sdr} provides drivers for this purpose.")
+ (license license:gpl2+)))