aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 22:09:31 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:10 +0200
commitb723dedf817e02eda27a222c770d0df3a43b39c0 (patch)
tree0ca96b7dd9632e96b080e7742bf81b74a35749d7
parentbc0081e76f23c03f0cd71c9f4fd6b1423a0c6dc1 (diff)
downloadguix-b723dedf817e02eda27a222c770d0df3a43b39c0.tar
guix-b723dedf817e02eda27a222c770d0df3a43b39c0.tar.gz
gnu: Add r-rook.
* gnu/packages/web.scm (r-rook): New variable.
-rw-r--r--gnu/packages/web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 5459a3051d..2649d68a21 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -4879,3 +4879,27 @@ responsive, and powerful applications with minimal effort.")
communicate with each other, with Shiny or without (i.e. static @code{.html}
files). It currently supports linked brushing and filtering.")
(license l:expat)))
+
+(define-public r-rook
+ (package
+ (name "r-rook")
+ (version "1.1-1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Rook" version))
+ (sha256
+ (base32
+ "00s9a0kr9rwxvlq433daxjk4ji8m0w60hjdprf502msw9kxfrx00"))))
+ (properties `((upstream-name . "Rook")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-brew" ,r-brew)))
+ (home-page "http://cran.r-project.org/web/packages/Rook")
+ (synopsis "Web server interface for R")
+ (description
+ "This package contains the Rook specification and convenience software
+for building and running Rook applications. A Rook application is an R
+reference class object that implements a @code{call} method or an R closure
+that takes exactly one argument, an environment, and returns a list with three
+named elements: the @code{status}, the @code{headers}, and the @code{body}.")
+ (license l:gpl2)))