aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-20 13:58:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-20 14:00:04 +0200
commita8cd352304807ef60d06c35da07c5456f036688c (patch)
tree6abc6dc3759d6948ce1526ea577b8b57d31557c6
parent92a1cb92858b9a413c6d043ea0c135def16df91a (diff)
downloadguix-a8cd352304807ef60d06c35da07c5456f036688c.tar
guix-a8cd352304807ef60d06c35da07c5456f036688c.tar.gz
gnu: r-minimal: Work around failure to embed reference to "which".
* gnu/packages/statistics.scm (r-minimal)[arguments]: Add phase "patch-which". [native-inputs]: Move "which" from here... [propagated-inputs]: ...to here.
-rw-r--r--gnu/packages/statistics.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 80465ea102..883bc82c8d 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -126,6 +126,12 @@ be output in text, PostScript, PDF or HTML.")
"PKG_BUILT_STAMP=1970-01-01")
#:phases
(modify-phases %standard-phases
+ ;; FIXME: see bug #28157.
+ (add-before 'configure 'patch-which
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "src/library/base/R/unix/system.unix.R"
+ (("@WHICH@") "which"))
+ #t))
(add-before 'configure 'patch-uname
(lambda* (#:key inputs #:allow-other-keys)
(let ((uname-bin (string-append (assoc-ref inputs "coreutils")
@@ -227,7 +233,6 @@ be output in text, PostScript, PDF or HTML.")
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo) ; for building HTML manuals
- ("which" ,which) ; for tests/Examples/base-Ex.R
("tzdata" ,tzdata-2017a)
("xz" ,xz)))
(inputs
@@ -246,6 +251,9 @@ be output in text, PostScript, PDF or HTML.")
("pcre" ,pcre)
("readline" ,readline)
("zlib" ,zlib)))
+ ;; FIXME: By default Sys.which embeds a reference to "which", but this
+ ;; reference is not detected by Guix (see bug #28157).
+ (propagated-inputs `(("which" ,which)))
(native-search-paths
(list (search-path-specification
(variable "R_LIBS_SITE")