aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 21:46:26 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:09 +0200
commita7f0faa2042991525355b36e39663fd8714d6cf6 (patch)
treee4ab8e63ffdfc712abcf7d443c7c6a4dd15ab8ac
parentf2e974e1a2c1ef1341484d852123fc88919621af (diff)
downloadguix-a7f0faa2042991525355b36e39663fd8714d6cf6.tar
guix-a7f0faa2042991525355b36e39663fd8714d6cf6.tar.gz
gnu: Add r-ff.
* gnu/packages/cran.scm (r-ff): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c959beee0e..b1cb0c4092 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -387,3 +387,24 @@ require repeated look-ups. It is slightly faster that R's built-in
@code{match} function on first match against a table, but extremely fast on
any subsequent lookup as it keeps the hash table in memory.")
(license license:gpl2)))
+
+(define-public r-ff
+ (package
+ (name "r-ff")
+ (version "2.2-13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "ff" version))
+ (sha256
+ (base32
+ "1nvd6kx46xzyc99a44mgynd94pvd2h495m5a7b1g67k5w2phiywb"))))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-bit" ,r-bit)))
+ (home-page "http://ff.r-forge.r-project.org/")
+ (synopsis "Memory-efficient storage of large data on disk and access functions")
+ (description
+ "This package provides data structures that are stored on disk but
+behave (almost) as if they were in RAM by transparently mapping only a section
+in main memory.")
+ (license license:gpl2)))