aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-08-18 14:13:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2017-08-19 02:17:41 +0200
commit865aacc9fae1a04f14ea2d7066c523192c79f027 (patch)
tree8c5b52b38b6a640aeb26d710a334cd8547f847f4
parentd9f15d7e48bc7c361b8a88849542d9f5d7442126 (diff)
downloadguix-865aacc9fae1a04f14ea2d7066c523192c79f027.tar
guix-865aacc9fae1a04f14ea2d7066c523192c79f027.tar.gz
gnu: Remove libgames-support.
It was simply the old name (and version) of libgnome-games-support. * gnu/packages/gnome.scm (libgames-support): Remove variable. Move the inherited fields... (libgnome-games-support): ...to here.
-rw-r--r--gnu/packages/gnome.scm28
1 files changed, 7 insertions, 21 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index f17db8fe13..f143155933 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -3335,10 +3335,10 @@ write applications that need to store structured data as well as make complex
queries upon that data.")
(license license:lgpl2.1+)))
-(define-public libgames-support
+(define-public libgnome-games-support
(package
- (name "libgames-support")
- (version "1.0.2")
+ (name "libgnome-games-support")
+ (version "1.2.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -3346,14 +3346,14 @@ queries upon that data.")
name "-" version ".tar.xz"))
(sha256
(base32
- "0rms2ksiv7j9944km7r87q22nh05si1fisn5xm3z4zy5vpcfi5mh"))))
+ "04qbgcgmc01sinhbqdljiny8q868l01nkdawj8wrnqnd1i8czvsg"))))
(build-system gnu-build-system)
(arguments
'(#:phases
(modify-phases %standard-phases
(add-before 'check 'pre-check
(lambda _
- ;; tests require a writable HOME.
+ ;; Tests require a writable HOME.
(setenv "HOME" (getcwd))
#t)))))
(native-inputs
@@ -3361,30 +3361,16 @@ queries upon that data.")
("pkg-config" ,pkg-config)
("vala" ,vala)))
(propagated-inputs
- ;; Required by libgames-support-1.0.pc
+ ;; Required by libgnome-games-support-1.0.pc
`(("gtk+" ,gtk+)
("libgee" ,libgee)))
(home-page "https://www.gnome.org/")
(synopsis "Useful functionality shared among GNOME games")
(description
- "libgames-support is a small library intended for internal use by
+ "libgnome-games-support is a small library intended for internal use by
GNOME Games, but it may be used by others.")
(license license:lgpl3+)))
-(define-public libgnome-games-support
- (package
- (inherit libgames-support)
- (name "libgnome-games-support")
- (version "1.2.2")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnome/sources/" name "/"
- (version-major+minor version) "/"
- name "-" version ".tar.xz"))
- (sha256
- (base32
- "04qbgcgmc01sinhbqdljiny8q868l01nkdawj8wrnqnd1i8czvsg"))))))
-
(define-public gnome-klotski
(package
(name "gnome-klotski")