aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-08-18 14:43:55 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-08-20 10:52:55 +0530
commit6a84ec8eb3e58f22e2961016722ae01e464cb8f4 (patch)
tree4978198f56232d6b74c08c4f51b011478181e0ab
parent36ed934dfe0bab2db62f7581ee0b874421220325 (diff)
downloadguix-6a84ec8eb3e58f22e2961016722ae01e464cb8f4.tar
guix-6a84ec8eb3e58f22e2961016722ae01e464cb8f4.tar.gz
gnu: Add libinfinity.
* gnu/packages/gobby.scm (libinfinity): New variable.
-rw-r--r--gnu/packages/gobby.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/gobby.scm b/gnu/packages/gobby.scm
index 961028d00a..897a6ac425 100644
--- a/gnu/packages/gobby.scm
+++ b/gnu/packages/gobby.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
+;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -25,6 +26,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gsasl)
#:use-module (gnu packages gtk)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages tls)
@@ -129,3 +131,35 @@ documents in one session. Obby is used by the Gobby collaborative editor.")
a multi-user chat. Gobby allows multiple users to edit the same document
together over the internet in real-time.")
(license license:gpl2+)))
+
+(define-public libinfinity
+ (package
+ (name "libinfinity")
+ (version "0.6.8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://releases.0x539.de/libinfinity/libinfinity-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0nylsb6qz9pjw3agjp27c4za205i6zg6i5g1vgs5vbdnbh77wkhc"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("gsasl" ,gsasl)
+ ("gtk+" ,gtk+-2)
+ ("libxml2" ,libxml2)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (arguments
+ `(#:configure-flags (list "--with-inftextgtk"
+ "--with-infgtk")))
+ (home-page "https://gobby.github.io/")
+ (synopsis "Infininote protocol implementation")
+ (description "libinfinity is a library to build collaborative text
+editors. Changes to the text buffers are synced to all other clients over a
+central server. Even though a central server is involved, the local user sees
+his changes applied instantly and the merging is done on the individual
+clients.")
+ (license license:lgpl2.1+)))