aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 22:14:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:10 +0200
commit6427e62005fe5176ff61a5eb0b120b6aa127082f (patch)
treef926dbeec4c978453add679d7354cfc803746828
parente389d10f559911224b960c88f80fcbbabe0bb632 (diff)
downloadguix-6427e62005fe5176ff61a5eb0b120b6aa127082f.tar
guix-6427e62005fe5176ff61a5eb0b120b6aa127082f.tar.gz
gnu: Add r-lmoments.
* gnu/packages/cran.scm (r-lmoments): New variable.
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 88e275c738..7bf8e1e134 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -595,3 +595,25 @@ print, summary, etc.")
and other distributions related to the eigenvalues of large Wishart
matrices.")
(license license:bsd-3)))
+
+(define-public r-lmoments
+ (package
+ (name "r-lmoments")
+ (version "1.2-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Lmoments" version))
+ (sha256
+ (base32
+ "13p0r4w16jvjnyjmkhkp3dwdfr1gap2l0k4k5jy41m8nc5fvcx79"))))
+ (properties `((upstream-name . "Lmoments")))
+ (build-system r-build-system)
+ (home-page "http://www.tilastotiede.fi/juha_karvanen.html")
+ (synopsis "L-moments and quantile mixtures")
+ (description
+ "This package contains functions to estimate L-moments and trimmed
+L-moments from the data. It also contains functions to estimate the
+parameters of the normal polynomial quantile mixture and the Cauchy polynomial
+quantile mixture from L-moments and trimmed L-moments.")
+ (license license:gpl2)))