aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Wingo <wingo@igalia.com>2017-08-20 11:29:37 +0200
committerAndy Wingo <wingo@igalia.com>2017-08-20 11:30:43 +0200
commit50631fe933037977cf54140d0cd473cea9ea1994 (patch)
tree91ccfc87f6448651b38829cb7344f628aa387e64
parent63ad9b80c76f08dbb39dceff5e8702ade3afd628 (diff)
downloadguix-50631fe933037977cf54140d0cd473cea9ea1994.tar
guix-50631fe933037977cf54140d0cd473cea9ea1994.tar.gz
gnu: gobby: Re-add Gobby 0.4.
* gnu/packages/gobby.scm (gobby-0.4): New variable.
-rw-r--r--gnu/packages/gobby.scm42
1 files changed, 41 insertions, 1 deletions
diff --git a/gnu/packages/gobby.scm b/gnu/packages/gobby.scm
index 37b1c158e0..45ebed7c43 100644
--- a/gnu/packages/gobby.scm
+++ b/gnu/packages/gobby.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2016 Andy Wingo <wingo@igalia.com>
+;;; Copyright © 2016, 2017 Andy Wingo <wingo@igalia.com>
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
@@ -98,6 +98,46 @@
documents in one session. Obby is used by the Gobby collaborative editor.")
(license license:gpl2+)))
+;; Although there is a newer version of Gobby defined below, the protocols are
+;; incompatible; you need Gobby 0.4 if you want to connect to servers running
+;; the 0.4 protocol.
+(define-public gobby-0.4
+ (package
+ (name "gobby")
+ (version "0.4.13")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://releases.0x539.de/gobby/gobby-"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0w8q01lf6bcdz537b29m7rwlbc7k87b12vnpm1h6219ypvzqkgcc"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("intltool" ,intltool)))
+ (inputs
+ `(("libxml++-2" ,libxml++-2)
+ ("gnutls" ,gnutls)
+ ("gtkmm-2" ,gtkmm-2)
+ ("gtksourceview-2" ,gtksourceview-2)
+ ("libnet6" ,libnet6)
+ ("obby" ,obby)))
+ (arguments
+ ;; Required by libsigc++.
+ `(#:configure-flags '("CXXFLAGS=-std=c++11")))
+ (home-page "https://gobby.github.io/")
+ (synopsis "Collaborative editor")
+ (description
+ "Collaborative editor that supports multiple documents in one session and
+a multi-user chat. Gobby allows multiple users to edit the same document
+together over the internet in real-time.
+
+This is the older 0.4 version of Gobby. Use this version only if you need to
+connect to a server running the old 0.4 protocol.")
+ (license license:gpl2+)))
+
(define-public gobby
(package
(name "gobby")