aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 17:57:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:25:47 +0200
commit2856369fad5d841aa1d46c359e67dc16aeba5657 (patch)
treec24d38007922a43b683169fb26f1f4f72c142ac5
parent4847a62ea9414dad19d4d44ee70099fbb8a691ca (diff)
downloadguix-2856369fad5d841aa1d46c359e67dc16aeba5657.tar
guix-2856369fad5d841aa1d46c359e67dc16aeba5657.tar.gz
gnu: Add r-circlize.
* gnu/packages/cran.scm (r-circlize): New variable.
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 7179ceb5c6..0fc158768d 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -233,3 +233,33 @@ ellipses, circles, cylinders, arrows, ...")
"This package provides more controls on the option values such as
validation and filtering on the values, making options invisible or private.")
(license license:gpl2+)))
+
+(define-public r-circlize
+ (package
+ (name "r-circlize")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "circlize" version))
+ (sha256
+ (base32
+ "0p1zx1aawkblz48kzzfn5w1k3lbwv9wrk1k5gcfjrr2b4sz1pp5b"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-colorspace" ,r-colorspace)
+ ("r-globaloptions" ,r-globaloptions)
+ ("r-shape" ,r-shape)))
+ (home-page "https://github.com/jokergoo/circlize")
+ (synopsis "Circular visualization")
+ (description
+ "Circular layout is an efficient way for the visualization of huge
+amounts of information. This package provides an implementation of circular
+layout generation in R as well as an enhancement of available software. The
+flexibility of the package is based on the usage of low-level graphics
+functions such that self-defined high-level graphics can be easily implemented
+by users for specific purposes. Together with the seamless connection between
+the powerful computational and visual environment in R, it gives users more
+convenience and freedom to design figures for better understanding complex
+patterns behind multiple dimensional data.")
+ (license license:gpl2+)))