aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-15 16:05:38 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:13 +0200
commit05e8a3ef0f68810cffd467e07be9abc0ece59552 (patch)
tree34d31131799dfed6bfea66b1ad08092180309812
parentabcb849405ba75af41f8e090af587bc999667b0f (diff)
downloadguix-05e8a3ef0f68810cffd467e07be9abc0ece59552.tar
guix-05e8a3ef0f68810cffd467e07be9abc0ece59552.tar.gz
gnu: Add r-ksamples.
* gnu/packages/cran.scm (r-ksamples): New variable.
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d1f684e374..bb7576352f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -900,3 +900,31 @@ coefficient, Johnson distributions, normal scores and generalized
hypergeometric distributions. In addition two random number generators of
George Marsaglia are included.")
(license license:gpl2+)))
+
+(define-public r-ksamples
+ (package
+ (name "r-ksamples")
+ (version "1.2-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "kSamples" version))
+ (sha256
+ (base32
+ "1pbam0zqq44slpxdgl2s2fsfdgl7i0pgm8bzlvnm0fy0na24bgdj"))))
+ (properties `((upstream-name . "kSamples")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-suppdists" ,r-suppdists)))
+ (home-page "http://cran.r-project.org/web/packages/kSamples")
+ (synopsis "K-Sample rank tests and their combinations")
+ (description
+ "This package provides tools to compares k samples using the
+Anderson-Darling test, Kruskal-Wallis type tests with different rank score
+criteria, Steel's multiple comparison test, and the Jonckheere-Terpstra (JT)
+test. It computes asymptotic, simulated or (limited) exact P-values, all
+valid under randomization, with or without ties, or conditionally under random
+sampling from populations, given the observed tie pattern. Except for Steel's
+test and the JT test it also combines these tests across several blocks of
+samples.")
+ (license license:gpl2+)))