aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-08-14 19:56:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-08-17 17:26:08 +0200
commit05486604205567c47cf835277009b9897671b5ab (patch)
tree85711115a2ff0372bb5c195d58c4f39e0cb244a3
parenteb60149eeecac6276b8c98ee0855d61a2c7a527b (diff)
downloadguix-05486604205567c47cf835277009b9897671b5ab.tar
guix-05486604205567c47cf835277009b9897671b5ab.tar.gz
gnu: Add r-compare.
* gnu/packages/cran.scm (r-compare): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 83f246d4d0..25f52a1433 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -288,3 +288,24 @@ continuous power law distributions. Additionally, a goodness-of-fit based
approach is used to estimate the lower cut-off for the scaling region.")
;; Any of these GPL versions.
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-compare
+ (package
+ (name "r-compare")
+ (version "0.2-6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "compare" version))
+ (sha256
+ (base32
+ "0k9zms930b5dz9gy8414li21wy0zg9x9vp7301v5cvyfi0g7xzgw"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/compare")
+ (synopsis "Comparing objects for differences")
+ (description
+ "This package provides functions to compare a model object to a
+comparison object. If the objects are not identical, the functions can be
+instructed to explore various modifications of the objects (e.g., sorting
+rows, dropping names) to see if the modified versions are identical.")
+ (license license:gpl2+)))