aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-07 16:51:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-07 16:51:26 +0200
commitfcb5493793ca43c159fcb87e1b9d0b1e93430e5b (patch)
tree3ce81b642d4f7667c5362d2ecea22dc8e3dd4fba
parent4f5fe46388eb70055b6935df053f74b7ccdaf55f (diff)
downloadguix-fcb5493793ca43c159fcb87e1b9d0b1e93430e5b.tar
guix-fcb5493793ca43c159fcb87e1b9d0b1e93430e5b.tar.gz
gnu: Python: Avoid needless reference on coreutils.
* gnu/packages/python.scm (python-2.7)[arguments]: Pass "INSTALL" and "MKDIR_P" in <#:configure-flags>.
-rw-r--r--gnu/packages/python.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d834cda915..68ea23ff57 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -143,6 +143,12 @@
"--with-system-ffi" ;build ctypes
"--with-ensurepip=install" ;install pip and setuptools
"--enable-unicode=ucs4"
+
+ ;; Prevent the installed _sysconfigdata.py from retaining a reference
+ ;; to coreutils.
+ "INSTALL=install -c"
+ "MKDIR_P=mkdir -p"
+
(string-append "LDFLAGS=-Wl,-rpath="
(assoc-ref %outputs "out") "/lib"))
;; With no -j argument tests use all available cpus, so provide one.