aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-03 15:40:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-03 15:40:28 +0200
commitf03cda4d1e4415a5c1e83b4c8280724cd0ffa05c (patch)
treef19e7d01b3b7596400cbb1a89326da9d7fbcc92f
parent6002a0b635f821019fd7b10d4eefe7f4eb0eee58 (diff)
downloadguix-f03cda4d1e4415a5c1e83b4c8280724cd0ffa05c.tar
guix-f03cda4d1e4415a5c1e83b4c8280724cd0ffa05c.tar.gz
gnu: lash: Add dependency on libtirpc.
* gnu/packages/audio.scm (lash)[arguments]: Add <#:make-flags>. [inputs]: Add LIBTIRPC.
-rw-r--r--gnu/packages/audio.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 44318bc450..b9217dfa53 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -75,6 +75,7 @@
#:use-module (gnu packages icu4c)
#:use-module (gnu packages image)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages qt)
#:use-module (gnu packages libbsd)
#:use-module (gnu packages linux)
@@ -1683,7 +1684,12 @@ to be plugged into a wide range of audio synthesis and recording packages.")
"12z1vx3krrzsfccpah9xjs68900xvr7bw92wx8np5871i2yv47iw"))))
(build-system gnu-build-system)
(arguments
- '(#:phases
+ '(;; Glibc no longer includes Sun RPC support, so tell the build system
+ ;; to use libtirpc instead.
+ #:make-flags (list (string-append "CFLAGS=-I"
+ (assoc-ref %build-inputs "libtirpc")
+ "/include/tirpc -ltirpc"))
+ #:phases
(modify-phases %standard-phases
;; lashd embeds an ancient version of sigsegv so we just skip it
(add-after 'unpack 'skip-lashd
@@ -1696,6 +1702,7 @@ to be plugged into a wide range of audio synthesis and recording packages.")
`(("bdb" ,bdb)
("gtk" ,gtk+-2)
("jack" ,jack-1)
+ ("libtirpc" ,libtirpc)
("readline" ,readline)
("python" ,python-2)))
;; According to pkg-config, packages depending on lash also need to have