aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-07 18:53:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-07 18:53:32 +0200
commitc4fa39188a9f198c99de528794cc7b3c4a053911 (patch)
tree490ec5d0fbd9c0c6f175000cba090b2796a1d3fe
parentb0dc2454cc7288148e108156a8bedbb1947115a9 (diff)
downloadguix-c4fa39188a9f198c99de528794cc7b3c4a053911.tar
guix-c4fa39188a9f198c99de528794cc7b3c4a053911.tar.gz
gnu: graphite2: Build against Python 3.
Previously, the Python tests were skipped, because they require Python 3. * gnu/packages/fontutils.scm (graphite2)[arguments]: New field. [native-inputs]: Change PYTHON-2 and PYTHON2-FONTTOOLS to PYTHON and PYTHON-FONTTOOLS.
-rw-r--r--gnu/packages/fontutils.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index 818d77f127..725d3ac878 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -9,6 +9,7 @@
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2019 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -438,9 +439,20 @@ applications should be.")
(base32
"01jzhwnj1c3d68dmw15jdxly0hwkmd8ja4kw755rbkykn1ly2qyx"))))
(build-system cmake-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'adjust-test-PYTHONPATH
+ (lambda _
+ ;; Tell the build system not to override PYTHONPATH
+ ;; while running the Python tests.
+ (substitute* "Graphite.cmake"
+ (("ENVIRONMENT PYTHONPATH=")
+ (string-append "ENVIRONMENT PYTHONPATH="
+ (getenv "PYTHONPATH") ":")))
+ #t)))))
(native-inputs
- `(("python" ,python-2) ; because of "import imap" in tests
- ("python-fonttools" ,python2-fonttools)))
+ `(("python" ,python)
+ ("python-fonttools" ,python-fonttools)))
(inputs
`(("freetype" ,freetype)))
(synopsis "Reimplementation of the SIL Graphite text processing engine")