aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-07 18:08:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-07 18:38:19 +0200
commitb0dc2454cc7288148e108156a8bedbb1947115a9 (patch)
tree19c6fcd8f8178d119d04ae8b6ef4cb19d9fd97ce
parentd0a52e65b53d05790b307a2b99172fa38dcd7619 (diff)
downloadguix-b0dc2454cc7288148e108156a8bedbb1947115a9.tar
guix-b0dc2454cc7288148e108156a8bedbb1947115a9.tar.gz
gnu: zziplib: Don't run failing tests.
* gnu/packages/compression.scm (zziplib)[arguments]: Set <#:test-target>.
-rw-r--r--gnu/packages/compression.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 1ca88fe78c..1321791841 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -1588,7 +1588,12 @@ recreates the stored directory structure by default.")
(lambda _
(for-each make-file-writable
(find-files "test" #:directories? #t))
- #t)))))
+ #t)))
+
+ ;; XXX: The default test target attempts to download external resources and
+ ;; fails without error: <https://github.com/gdraheim/zziplib/issues/53>.
+ ;; To prevent confusing log messages, just run a simple zip test that works.
+ #:test-target "check-readme"))
(inputs
`(("zlib" ,zlib)))
(native-inputs `(("perl" ,perl) ; for the documentation