aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-07 19:19:39 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-07 19:19:39 +0200
commit794c773d0cbc49c1bd7d112d820bb9a7a19f3667 (patch)
tree3825fed4fecbddb365f5263da63bf4d4f088b6ed
parentc43b090326d5d73b54cab7ae41b7d1119b402d65 (diff)
downloadguix-794c773d0cbc49c1bd7d112d820bb9a7a19f3667.tar
guix-794c773d0cbc49c1bd7d112d820bb9a7a19f3667.tar.gz
gnu: libinput: Use the 'release' Meson build type.
* gnu/packages/freedesktop.scm (libinput)[arguments]: Add <#:build-type>.
-rw-r--r--gnu/packages/freedesktop.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index d77d6c58c4..7cd959d2f1 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -162,7 +162,12 @@ freedesktop.org project.")
"07a0w7rak7rvnh6g4j0akwjxwinxfszc1xi9mrx12fv82k3mgsyk"))))
(build-system meson-build-system)
(arguments
- `(#:configure-flags '("-Ddocumentation=false")))
+ `(#:configure-flags '("-Ddocumentation=false")
+
+ ;; XXX: Using 'debug' or 'debugoptimized' pulls in an additional test that
+ ;; hangs, and the comments around it suggests that we should be using this
+ ;; Meson target anyway.
+ #:build-type "release"))
(native-inputs
`(("check" ,check)
("pkg-config" ,pkg-config)))