aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJacob MacDonald <jaccarmac@gmail.com>2019-06-07 05:48:14 -0500
committerLudovic Courtès <ludo@gnu.org>2019-07-02 18:33:52 +0200
commit252a4d59368d3fea9c63f12592044b856af20afe (patch)
tree6b60a35004b842d40ec68d549d5fa5a4fd4186d0
parent2c4e4bc6583579e0366849d588563d81e9802a0c (diff)
downloadguix-252a4d59368d3fea9c63f12592044b856af20afe.tar
guix-252a4d59368d3fea9c63f12592044b856af20afe.tar.gz
gnu: Add ghc-validation.
* gnu/packages/haskell.scm (ghc-validation): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 63d4360182..d3ff27412f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11608,6 +11608,60 @@ default)
@end itemize")
(license license:bsd-3)))
+(define-public ghc-validation
+ (package
+ (name "ghc-validation")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/validation/validation-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1acj7mh3581ks405xswxw6667z7y1y0slisg6jvp6chc191ji9l5"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'add-setup-script
+ (lambda _
+ ;; The usual "Setup.hs" script is missing from the source.
+ (with-output-to-file "Setup.hs"
+ (lambda ()
+ (format #t "import Distribution.Simple~%")
+ (format #t "main = defaultMain~%"))))))))
+ (inputs
+ `(("ghc-semigroups" ,ghc-semigroups)
+ ("ghc-semigroupoids" ,ghc-semigroupoids)
+ ("ghc-bifunctors" ,ghc-bifunctors)
+ ("ghc-lens" ,ghc-lens)))
+ (native-inputs
+ `(("ghc-hedgehog" ,ghc-hedgehog)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://github.com/qfpl/validation")
+ (synopsis
+ "Data-type like Either but with an accumulating Applicative")
+ (description
+ "A data-type like Either but with differing properties and type-class
+instances.
+
+Library support is provided for this different representation, including
+@code{lens}-related functions for converting between each and abstracting over
+their similarities.
+
+The @code{Validation} data type is isomorphic to @code{Either}, but has an
+instance of @code{Applicative} that accumulates on the error side. That is to
+say, if two (or more) errors are encountered, they are appended using a
+@{Semigroup} operation.
+
+As a consequence of this @code{Applicative} instance, there is no
+corresponding @code{Bind} or @code{Monad} instance. @code{Validation} is an
+example of, \"An applicative functor that is not a monad.\"")
+ (license license:bsd-3)))
+
(define-public ghc-concurrent-output
(package
(name "ghc-concurrent-output")