aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-07-17 20:46:19 +0100
committerChristopher Baines <mail@cbaines.net>2018-07-29 17:57:52 +0100
commit89b48821767d78fede67065028ee0a0f3f172acb (patch)
tree273ecb3e8821905c550d97e36e87114a6b1feadd
parentcfa6cc4d9a02447e4c8892df9dee9225e748291f (diff)
downloadguix-89b48821767d78fede67065028ee0a0f3f172acb.tar
guix-89b48821767d78fede67065028ee0a0f3f172acb.tar.gz
gnu: Remove duplicated ghc-th-lift-instances.
It was first added in a6d1c4e75a76399c8d82a9570db5cd14351f661b, then again in ff7dd11f0a4fd6ca947cfa40cec42628fde44667. * gnu/packages/haskell.scm (ghc-th-lift-instances): Remove duplicated package definition.
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 0 insertions, 25 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8d2dcba208..d9d39fb721 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -9221,31 +9221,6 @@ connections.")
from aeson.")
(license license:bsd-3)))
-(define-public ghc-th-lift-instances
- (package
- (name "ghc-th-lift-instances")
- (version "0.1.11")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/"
- "th-lift-instances-" version "/"
- "th-lift-instances-" version ".tar.gz"))
- (sha256
- (base32
- "1f56cp6ckcalld5jchv0kxpjkwcsixd7smd0g7r8cg67ppx6m90x"))))
- (build-system haskell-build-system)
- (inputs `(("ghc-th-lift" ,ghc-th-lift)
- ("ghc-vector" ,ghc-vector)
- ("ghc-text" ,ghc-text)))
- (native-inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
- (home-page "https://github.com/bennofs/th-lift-instances")
- (synopsis "Lift instances for template-haskell for common data types")
- (description "Most data types in the Haskell platform do not have Lift
-instances. This package provides orphan instances for containers, text,
-bytestring and vector.")
- (license license:bsd-3)))
-
(define-public ghc-generics-sop
(package
(name "ghc-generics-sop")