aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Eisenmann <eisenmann@fn.de>2018-09-26 17:01:33 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-26 23:40:37 +0200
commite15ede6e28cfaf5fe951faf88d7c1e3213a476a4 (patch)
treec92566cc9c65e10a64a7c8da47ea5d7d2a1e0651
parent09b7300c01a8e7100467c6caae9b2c8d8e673971 (diff)
downloadguix-e15ede6e28cfaf5fe951faf88d7c1e3213a476a4.tar
guix-e15ede6e28cfaf5fe951faf88d7c1e3213a476a4.tar.gz
gnu: enlightenment: Fix initial locale and keyboard selection.
* gnu/packages/enlightenment.scm (enlightenment)[arguments]: In 'set-system-actions', set absolute file name to 'locale' and 'xorg.lst'. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/enlightenment.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 45dc1dbbeb..c7812e8874 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2015, 2016, 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2017 Nils Gillmann <ng0@n0.is>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Timo Eisenmann <eisenmann@fn.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -268,13 +269,19 @@ Libraries with some extra bells and whistles.")
(add-before 'configure 'set-system-actions
(lambda* (#:key inputs #:allow-other-keys)
(let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
- (utils (assoc-ref inputs "util-linux")))
+ (utils (assoc-ref inputs "util-linux"))
+ (libc (assoc-ref inputs "libc")))
;; We need to patch the path to 'base.lst' to be able
;; to switch the keyboard layout in E.
- (substitute* "src/modules/xkbswitch/e_mod_parse.c"
+ (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
+ "src/modules/wizard/page_011.c")
(("/usr/share/X11/xkb/rules/xorg.lst")
(string-append xkeyboard
"/share/X11/xkb/rules/base.lst")))
+ (substitute* (list "src/bin/e_intl.c"
+ "src/modules/conf_intl/e_int_config_intl.c"
+ "src/modules/wizard/page_010.c")
+ (("locale -a") (string-append libc "/bin/locale -a")))
(substitute* "src/modules/everything/evry_plug_apps.c"
(("/usr/bin/") ""))
(substitute* "configure"