aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-09-24 16:20:19 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-09-24 16:20:19 +0200
commitd08b3258435254cc6ade95b84a6c53e59cc191e6 (patch)
tree1ec5dd59e83a41d0bdc8b9e940b3106a3b2703fd
parent53c64d7c9303d52cbacdaca5d182175d472c53db (diff)
downloadguix-d08b3258435254cc6ade95b84a6c53e59cc191e6.tar
guix-d08b3258435254cc6ade95b84a6c53e59cc191e6.tar.gz
gnu: Add python-grequests.
* gnu/packages/python-web.scm (python-grequests): New variable.
-rw-r--r--gnu/packages/python-web.scm25
1 files changed, 24 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 226b9b631b..6ded2f75ab 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2015, 2016, 2017 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2016, 2017 Nils Gillmann <ng0@n0.is>
@@ -1592,6 +1592,29 @@ library.")
(define-public python2-responses
(package-with-python2 python-responses))
+(define-public python-grequests
+ (package
+ (name "python-grequests")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "grequests" version))
+ (sha256
+ (base32
+ "1j9icncllbkv7x5719b20mx670c6q1jrdx1sakskkarvx3pc8h8g"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-gevent" ,python-gevent)
+ ("python-requests" ,python-requests)))
+ (native-inputs
+ `(("python-nose" ,python-nose)))
+ (home-page "https://github.com/kennethreitz/grequests")
+ (synopsis "Python library for asynchronous HTTP requests")
+ (description "GRequests is a Python library that allows you to use
+@code{Requests} with @code{Gevent} to make asynchronous HTTP Requests easily")
+ (license license:bsd-2)))
+
(define-public python-geventhttpclient
(package
(name "python-geventhttpclient")