aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 10:15:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-27 03:51:07 +0200
commitb733dbc0fb5bd1648f1fdce6471f048886e69e73 (patch)
tree32bb7fb99dafc52840cb759b09a7e3ab724747b5
parent3d190d6a219d03dc94c8d33614766df0fed1473f (diff)
downloadguix-b733dbc0fb5bd1648f1fdce6471f048886e69e73.tar
guix-b733dbc0fb5bd1648f1fdce6471f048886e69e73.tar.gz
gnu: python-setproctitle: Use INVOKE.
* gnu/packages/python.scm (python-setproctitle)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/python.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 5c6c79da88..4703d95a2d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -10482,7 +10482,7 @@ theme for the Sphinx documentation system. It's the default theme of Sphinx.")
(setenv "CC" "gcc")
;; No need to extend PYTHONPATH to find the built package, since
;; the Makefile will build anyway
- (zero? (system* "make" "check")))))))
+ (invoke "make" "check"))))))
(native-inputs
`(("procps" ,procps))) ; required for tests
(home-page