aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-08-26 23:31:10 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-26 00:33:01 +0200
commit5f33e9063b9b047801d0206e7a74eee8bf6fc52d (patch)
treed5b256ff1bb2a3b7170e0d43e78d6377bca0ee0b
parente789b85841aa013c4f6bd18f4dff99b30bf0b3a4 (diff)
downloadguix-5f33e9063b9b047801d0206e7a74eee8bf6fc52d.tar
guix-5f33e9063b9b047801d0206e7a74eee8bf6fc52d.tar.gz
gnu: varnish: Use absolute file name of "rm".
* gnu/packages/web.scm (varnish)[arguments]: Rename 'patch-bin-sh-phase to 'use-absolute-file-names and add substitution.
-rw-r--r--gnu/packages/web.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b6bee57f9f..26c2e9128a 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5019,12 +5019,14 @@ deployments.")
"--localstatedir=/var")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'patch-/bin/sh
+ (add-after 'unpack 'use-absolute-file-names
(lambda _
(substitute* '("bin/varnishtest/vtc_varnish.c"
"bin/varnishtest/vtc_process.c"
"bin/varnishd/mgt/mgt_vcc.c")
(("/bin/sh") (which "sh")))
+ (substitute* "bin/varnishd/mgt/mgt_shmem.c"
+ (("rm -rf") (string-append (which "rm") " -rf")))
#t))
(add-before 'install 'patch-Makefile
(lambda _