aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-27 03:47:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-27 03:51:06 +0200
commit3d190d6a219d03dc94c8d33614766df0fed1473f (patch)
tree743a0a0de934096071d56960a5f7005f00e95b4c
parentaf44f05af78e3187589c2c628c3d3436df7ceed0 (diff)
downloadguix-3d190d6a219d03dc94c8d33614766df0fed1473f.tar
guix-3d190d6a219d03dc94c8d33614766df0fed1473f.tar.gz
gnu: dico: Update to 2.7.
* gnu/packages/dico.scm (dico): Update to 2.7. [arguments]: Work around dodgy test in 'check' phase.
-rw-r--r--gnu/packages/dico.scm11
1 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/dico.scm b/gnu/packages/dico.scm
index a85987d9b1..d96dbb86d9 100644
--- a/gnu/packages/dico.scm
+++ b/gnu/packages/dico.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015, 2016, 2018 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2016, 2018 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,14 +38,14 @@
(define-public dico
(package
(name "dico")
- (version "2.6")
+ (version "2.7")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/dico/dico-"
version ".tar.xz"))
(sha256
(base32
- "0zmi041gv5nd5fmyzgdrgrsy2pvjaq9p8dvvhxwi842hiyng5b7i"))))
+ "0dg4aacnmlf3ljssd7dwh8z5644xzq8k1501mbsx8nz8p8a9mbsq"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags (list (string-append "--with-guile-site-dir=" %output
@@ -57,7 +58,11 @@
;; infrastructure. Gag it.
(setenv "GUILE_AUTO_COMPILE" "0")
(setenv "GUILE_WARN_DEPRECATED" "no")
- #t)))))
+ #t))
+ (replace 'check
+ (lambda _
+ ;; Test '71: append + dooffs + env' fails if $V is not 2.
+ (invoke "make" "check" "V=2"))))))
(inputs
`(("m4" ,m4) ;used at run time
("pcre" ,pcre)