aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 10:14:58 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-25 11:46:54 +0200
commit06e6b17bd7ab0258536c62c3639fba38134d84ae (patch)
tree841bb05c396b26929d48dc5ccd1e3506672ca9d6
parent6d7ca74ba60053ddd53636d5850d8ee97fb4ccf5 (diff)
downloadguix-06e6b17bd7ab0258536c62c3639fba38134d84ae.tar
guix-06e6b17bd7ab0258536c62c3639fba38134d84ae.tar.gz
gnu: python-pexpect: Use INVOKE.
* gnu/packages/python.scm (python-pexpect)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/python.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 86ce70254d..5c6c79da88 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4550,7 +4550,7 @@ displayed.")
;; Why does it not work? Delete for now.
(delete-file "tests/test_socket.py")
#t))
- (replace 'check (lambda _ (zero? (system* "nosetests" "-v")))))))
+ (replace 'check (lambda _ (invoke "nosetests" "-v"))))))
(native-inputs
`(("python-nose" ,python-nose)
("python-pytest" ,python-pytest)