aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2020-01-06 10:54:30 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2020-01-06 12:56:01 +0300
commite916a202a1deffccb18d60ebfd1623150f9293be (patch)
treed0575b24ff2148f1f36b86e52fd4d06b012f6f0e
parent0daf7e263a2bfbe2de4b9c6598ebf1fdc8fa3b61 (diff)
downloadguix-e916a202a1deffccb18d60ebfd1623150f9293be.tar
guix-e916a202a1deffccb18d60ebfd1623150f9293be.tar.gz
gnu: Add emacs-pfuture.
* gnu/packages/emacs-xyz.scm (emacs-pfuture): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index cae6a36858..ab052badbd 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17757,6 +17757,28 @@ experience by providing optional integration with other popular Emacs packages
like @code{company}, @code{flycheck}, and @code{projectile}.")
(license license:gpl3+)))
+(define-public emacs-pfuture
+ (let ((commit "368254ee30692c709400db413c347e18e76a8a55"))
+ (package
+ (name "emacs-pfuture")
+ (version (git-version "1.6" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Alexander-Miller/pfuture.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "096raqpjx84njws85r7pqq1wi9w9bjwkr0ga1mbbhlna1mfn3mg4"))))
+ (build-system emacs-build-system)
+ (home-page
+ "https://github.com/Alexander-Miller/pfuture")
+ (synopsis "Simple wrapper around asynchronous processes for Emacs")
+ (description "This package provides a simple wrapper around asynchronous
+processes for Emacs")
+ (license license:gpl3+))))
+
(define-public emacs-lsp-ui
(package
(name "emacs-lsp-ui")