aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-06 09:34:36 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-06 09:34:36 +0200
commitc83640728cc39edf8ef65a532b62c772f25ac9d3 (patch)
tree2c091e6e4ec531e2bbb7f5f30ca4fc2c72e4252a
parent957c683354a9c35c630dac16a1015b54d1909b81 (diff)
downloadguix-c83640728cc39edf8ef65a532b62c772f25ac9d3.tar
guix-c83640728cc39edf8ef65a532b62c772f25ac9d3.tar.gz
gnu: python-urwidtrees: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-urwidtrees)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 475f37f3ef..eeb073e85c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5620,15 +5620,16 @@ features useful for text console applications.")
(version "1.0.2")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; package author intends on distributing via github rather than pypi:
;; https://github.com/pazz/alot/issues/877#issuecomment-230173331
- (uri (string-append "https://github.com/pazz/urwidtrees/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/pazz/urwidtrees")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0d30lyd3s2a97rhqfax5w9ssqds2z6aydqx3c6j2c2lk3cb4ngvh"))))
+ "1n1kpidvkdnsqyb82vlvk78gmly96kh8351lqxn2pzgwwns6fml2"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; no tests