aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-01-06 09:39:24 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-01-06 09:39:24 +0200
commitac0ea38c2c1b928f6f1138512e71cb44dbbb88d7 (patch)
tree369ffb4a876cb729ed5b33641113845556d63dee
parent26bb7fc627cb4839e7ed73f6b0784635bf5a10e1 (diff)
downloadguix-ac0ea38c2c1b928f6f1138512e71cb44dbbb88d7.tar
guix-ac0ea38c2c1b928f6f1138512e71cb44dbbb88d7.tar.gz
gnu: python-whatever: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-whatever)[source]: Download using git-fetch.
-rw-r--r--gnu/packages/python-xyz.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 56deb57a56..e6f6e41a74 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14613,12 +14613,13 @@ files, and Makefiles.")
(version "0.6")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/Suor/whatever/archive/" version
- ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Suor/whatever")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1rchg9hrlvw4sn20lq1zspczr4x1pv57c02gv73igiqx1hqpy2nc"))
- (file-name (string-append name "-" version ".tar.gz"))))
+ (base32 "1q7ajgqjfivxqsqgnhp4lc4p6jxyh4zprcsdbpd6dw54inaf0av5"))))
(build-system python-build-system)
(arguments
`(#:phases