aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-01-04 22:53:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2020-01-05 20:45:22 +0100
commit94c621bdc0f4ada42f2117fcd4e51a492414890e (patch)
tree54f810aaf40c1a9c3b27438d38ed34819545521d
parent0dbd7c3c0baaf800c426ca46ce73a565ef339038 (diff)
downloadguix-94c621bdc0f4ada42f2117fcd4e51a492414890e.tar
guix-94c621bdc0f4ada42f2117fcd4e51a492414890e.tar.gz
gnu: Add cl-vectors.
* gnu/packages/lisp-xyz.scm (sbcl-cl-vectors, ecl-cl-vectors, cl-vectors): New variables.
-rw-r--r--gnu/packages/lisp-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index e9297f3a80..11f386ccfc 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -462,6 +462,25 @@ paths.")))
(define-public cl-paths-ttf
(sbcl-package->cl-source-package sbcl-cl-paths-ttf))
+(define-public sbcl-cl-vectors
+ (package
+ (inherit sbcl-cl-aa)
+ (name "sbcl-cl-vectors")
+ (arguments '(#:asd-file "cl-vectors.asd"))
+ (inputs
+ `(("cl-aa" ,sbcl-cl-aa)
+ ("cl-paths" ,sbcl-cl-paths)))
+ (synopsis "Create, transform and render anti-aliased vectorial paths")
+ (description
+ "This is a pure Common Lisp library to create, transform and render
+anti-aliased vectorial paths.")))
+
+(define-public ecl-cl-vectors
+ (sbcl-package->ecl-package sbcl-cl-vectors))
+
+(define-public cl-vectors
+ (sbcl-package->cl-source-package sbcl-cl-vectors))
+
(define-public sbcl-clx
(package
(name "sbcl-clx")