aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkanichos@yandex.ru <kanichos@yandex.ru>2020-01-01 13:59:49 +0300
committerLudovic Courtès <ludo@gnu.org>2020-01-06 16:31:54 +0100
commit5757c641f2c547a45cb65f00a57af971381e6a42 (patch)
tree6a367b0e1cc4ae2e473ab4ea47163a86da7c805d
parent562b4e47cdc7621c5eda10869be061d8cc2e82d9 (diff)
downloadguix-5757c641f2c547a45cb65f00a57af971381e6a42.tar
guix-5757c641f2c547a45cb65f00a57af971381e6a42.tar.gz
gnu: gnome-characters: Wrap program to provide the necessary Typelib files.
* gnu/packages/gnome.scm (gnome-characters)[arguments]: Add #:phases with a 'wrap' phase. [inputs]: Add GNOME-DESKTOP. Co-authored-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/gnome.scm16
1 files changed, 14 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index ec06e6d4d2..e71cc2fee2 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -548,7 +548,18 @@ to other formats.")
(base32
"08cwz39iwgsyyb2wqhb8vfbmh1cwfkgfiy7adp08w7rwqi99x3dp"))))
(build-system meson-build-system)
- (arguments '(#:glib-or-gtk? #t))
+ (arguments
+ `(#:glib-or-gtk? #t
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; GNOME Characters needs Typelib files from GTK and
+ ;; gnome-desktop.
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/gnome-characters")
+ `("GI_TYPELIB_PATH" ":" prefix
+ (,(getenv "GI_TYPELIB_PATH"))))
+ #t)))))
(native-inputs
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
@@ -558,7 +569,8 @@ to other formats.")
(inputs
`(("gjs" ,gjs)
("gtk+" ,gtk+)
- ("libunistring" ,libunistring)))
+ ("libunistring" ,libunistring)
+ ("gnome-desktop" ,gnome-desktop)))
(home-page "https://wiki.gnome.org/Apps/CharacterMap")
(synopsis "Find and insert unusual characters")
(description "Characters is a simple utility application to find